Bug #15850

Symbolic link to tslib in dummy package is missing

Added by Oliver Hader over 13 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Should have
Category:
Backend User Interface
Target version:
-
Start date:
2006-03-17
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
5
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I'm using TMENU_LAYERS and included the necessary file with
"page.includeLibs.tmenu_layers = media/scripts/tmenu_layers.php" in TypoScript.

In 3.8.1 dummy package there were several symbolic links in the root of that package:
media -> tslib/media
tslib -> typo3_src/tslib

Since the file structure changed in 4.0rc1 there are two ways to work around:

1) create the symlinks
media -> tslib/media
tslib -> typo3_src/typo3/sysext/cms/tslib

2) use "page.includeLibs.tmenu_layers = typo3_src/typo3/sysext/cms/tslib/media/scripts/tmenu_layers.php" in TypoScript

(issue imported from #M2911)

History

#1 Updated by Sebastian Kurfuerst over 13 years ago

Hi,
that is correct. All symlinks have been removed by default from the core. The files themselves have been updated, I suggest you use the option 2).

Also available in: Atom PDF