Bug #15899

Creating content element with new templavoila causes the following error when editing page properties

Added by David Toshack almost 14 years ago. Updated almost 14 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2006-03-26
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Warning: array_unique(): The argument should be an array in root_path_to_TYPO3core_directory/t3lib/class.t3lib_tceforms.php on line 2076

Warning: in_array(): Wrong datatype for second argument in root_path_to_TYPO3core_directory/t3lib/class.t3lib_tceforms.php on line 2087

Fatal error: Only variables can be passed by reference in root_path_to_TYPO3core_directory/t3lib/class.t3lib_tceforms.php on line 2088

Doesn't happen with TER version. Problem occured with HEAD & templavoila-0-6-0 tag

Seems to be something to do with language metadata. Corrosponding lines:

Line 2076: $editData['meta']['currentLangId'] = array_unique($editData['meta']['currentLangId']);

Line 2087: if (!in_array('DEF',$editData['meta']['currentLangId'])) {

Line 2088: array_unshift($editData['meta']['currentLangId'],'DEF');

(issue imported from #M2989)

History

#1 Updated by Robert Lemke almost 14 years ago

[check before 1.0.0]

#2 Updated by Robert Lemke almost 14 years ago

I checked this with TYPO3 4.0rc3 and TV 0.8.0, also had a look at the TCEforms code. I couldn't reproduce this, so for now I close the bug and move it to the TYPO3 core issues.

If it ever reappears or you can reproduce it with 4.0rc3 or later, please reopen this issue.

Also available in: Atom PDF