Bug #16080

Yet another table accessibility improvement

Added by J©rémy Lecour about 15 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
-
Start date:
2006-04-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

This is connected to the #0002405 report. I've posted it here to be in the correct category.
It's the patch requested by Sebastian Kurfuerst.

The purpose is to correct 2 features :
- be able to specify a 0 value in the border/cellapdding/cellspacing when creating a table
- add the row numbering, even for the last

--- class.tx_cssstyledcontent_pi1.orig.php 2006-04-24 09:18:49.000000000 0200
++ class.tx_cssstyledcontent_pi1.php 2006-04-24 09:19:27.000000000 0200
@ -213,7 +213,7 @
}
if (!$noStyles) {
$oddEven = $k%2 ? 'tr-odd' : 'tr-even';
- $rowAttribs = ($k>0 && ($rCount-1)==$k) ? ' class="'.$oddEven.' tr-last"' : ' class="'.$oddEven.' tr-'.$k.'"';
$rowAttribs = ($k>0 && ($rCount-1)==$k) ? ' class="'.$oddEven.' tr-last tr-'.$k.'"' : ' class="'.$oddEven.' tr-'.$k.'"';
}
$rows[$k]='
<tr'.$rowAttribs.'>'.implode('',$newCells).'
@ -849,9 +849,9 @

// Create table attributes array:
$tableTagParams = array();
- $tableTagParams['border'] = $this->cObj->data['table_border'] ? intval($this->cObj->data['table_border']) : $tableTagParams_conf['border'];
- $tableTagParams['cellspacing'] = $this->cObj->data['table_cellspacing'] ? intval($this->cObj->data['table_cellspacing']) : $tableTagParams_conf['cellspacing'];
- $tableTagParams['cellpadding'] = $this->cObj->data['table_cellpadding'] ? intval($this->cObj->data['table_cellpadding']) : $tableTagParams_conf['cellpadding'];
+ $tableTagParams['border'] = $this->cObj->data['table_border'] >= 0 ? intval($this->cObj->data['table_border']) : $tableTagParams_conf['border'];
+ $tableTagParams['cellspacing'] = $this->cObj->data['table_cellspacing'] >= 0 ? intval($this->cObj->data['table_cellspacing']) : $tableTagParams_conf['cellspacing'];
+ $tableTagParams['cellpadding'] = $this->cObj->data['table_cellpadding'] >= 0 ? intval($this->cObj->data['table_cellpadding']) : $tableTagParams_conf['cellpadding'];
$tableTagParams['bgcolor'] = isset($conf['color.'][$this->cObj->data['table_bgColor']]) ? $conf['color.'][$this->cObj->data['table_bgColor']] : $conf['color.']['default'];
// Return result:
(issue imported from #M3325)

Files

patch_tables.txt (1.78 KB) patch_tables.txt Administrator Admin, 2006-04-24 09:27

Related issues

Related to TYPO3 Core - Bug #14166: Content Type TABLE does not allow 0 cellspacingClosed2004-05-15

Actions
Has duplicate TYPO3 Core - Bug #15514: Yet another table accessibility improvementClosed2006-01-27

Actions
#1

Updated by Chris topher about 11 years ago

Related to #93.

#2

Updated by Ernesto Baschny about 9 years ago

  • Status changed from Accepted to Needs Feedback
  • Assignee deleted (Ernesto Baschny)
  • Target version deleted (0)
  • TYPO3 Version set to 4.5

Is this still an issue? Sorry for taking so long, but I unassign myself because I don't really have this problem.

#3

Updated by Alexander Opitz over 8 years ago

  • Status changed from Needs Feedback to Closed

No response over 9 month => closed

Also available in: Atom PDF