Bug #16510

Ext mng / compare: missing columns with auto_increments

Added by Stefan Kreisberg over 15 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2006-08-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:

I found a plugin where, for some strange reasons, one field was not created upon install of the extension. Nevertheless, the install tool, as well as ext. mng. has no problem of reproducing and displaying the error.

This would ordinary work fine, but with auto_increment values you need to specify the primary key as well in the same SQL stmt.

i.e. my problem was presented as if two sql stmts needed to be fired away:

1.
ALTER TABLE `tx_veguestbook_entries` ADD `uid` INT UNSIGNED NOT NULL AUTO_INCREMENT

2.
ALTER TABLE `tx_veguestbook_entries` PRIMARY KEY

This should of course have been:

ALTER TABLE `tx_veguestbook_entries` ADD `uid` INT UNSIGNED NOT NULL AUTO_INCREMENT PRIMARY KEY

Ofcourse this problem might only relate to extensions which exhibit this particular flaw, but AFAIK MySQL will not accept the SQL stmt. 1) since auto_increment should be pri key!

I'd ofcourse be happy to correct the issue if anyone can point me in the direction of the source to diff

:-)

(issue imported from #M4125)


Related issues

Is duplicate of TYPO3 Core - Bug #16509: Ext mng / compare: missing columns with auto_incrementsClosed2006-08-30

Actions
#1

Updated by Stefan Kreisberg over 15 years ago

whoops, sorry .. posted this one twice (doh!)
anyone - how do I remove the duplicant?

#2

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF