Feature #16539

.svn ignore option

Added by Michiel Roos almost 15 years ago. Updated over 14 years ago.

Status:
Closed
Priority:
Should have
Category:
Extension Manager
Target version:
-
Start date:
2006-09-08
Due date:
% Done:

0%

Estimated time:
PHP Version:
4
Tags:
Complexity:
Sprint Focus:

Description

When using extensions, there sometimes is the need to browse through the files in the extension and look at the source to see if a quick fix or extension is possible.

In this case it is very very annoying to see the list of files cluttered with a lot of .svn grub.

I know svn is nice to use. But it would be very nice to have an option to 'ignore' .svn directories and their contents on uploading a new revision of the extension to the ter.

Please find attached a diff against class.em_index.php which hardcodes a fix to ignore .svn files in the file listing in the backend. The same could be done for cvs.

Of course this could be made configurable.

(issue imported from #M4177)


Files

ignore.svn.diff (1.54 KB) ignore.svn.diff Administrator Admin, 2006-09-08 12:54

Related issues

Is duplicate of TYPO3 Core - Bug #16419: Upload to TER always transfers hidden or system filesClosedKarsten Dambekalns2006-08-01

Actions

No data to display

Also available in: Atom PDF