Bug #16611

stdWrap-property in stdWrap doesn't work like expected

Added by Irene Höppner about 14 years ago. Updated over 13 years ago.

Status:
Closed
Priority:
Should have
Category:
Communication
Target version:
-
Start date:
2006-09-30
Due date:
% Done:

0%

TYPO3 Version:
4.0
PHP Version:
4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you do something like this:

page.5 = TEXT
page.5.stdWrap.wrap = <div> | </div>

the wrap is beeing ignored.

The reason is the function call in class.tslib_content.php, line 3204:
if ($conf['stdWrap']) { $content=$this->stdWrap($content,$conf['stdWrap.']); }

It should be

if (isset($conf['stdWrap.'])) { $content=$this->stdWrap($content,$conf['stdWrap.']); }

The way it is now, you need something like
page.5.stdwrap = sldfjkls
to get the recursive stdWrap working, which makes no sense.

I guess the problem exists since the introduction of this property, which was 3.6 or 3.8.
(issue imported from #M4312)


Related issues

Related to TYPO3 Core - Bug #16909: ID 0004312 needs to be reopened due to misunderstanding Closed 2007-01-26

History

#1 Updated by Brian Slezak over 13 years ago

I've run across the same thing, and it is the simple fix that Irene describes above.

If one of the core guys come across this note, it only requires a one character fix.

-Brian

#2 Updated by Martin Kutschker over 13 years ago

This maybe is odd, but the way it always has been and is well documented in TSref:

http://typo3.org/documentation/document-library/references/doc_core_tsref/4.0.0/view/8/3/

#3 Updated by Martin Kutschker over 13 years ago

Fixec in SVN.

Also available in: Atom PDF