Bug #16910

PHP Error Message

Added by Karsten Hachmeister over 14 years ago. Updated over 14 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2007-01-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
5
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Sometimes I get the following error message.

Fatal error: Cannot delete class fe_loaddbgroup in /var/www/include/typo3_src-4.1beta3/typo3/sysext/cms/tslib/index_ts.php on line 422

Typo3 runs under Ubuntu Linux in a VMware Player. Mostly I get these error only once per day.

(issue imported from #M4872)

#1

Updated by Oliver Hader over 14 years ago

What is your exact PHP version? Possibly it's related to a PHP bug, see http://news.php.net/php.pecl.cvs/6605 and http://pecl.php.net/bugs/bug.php?id=8848

That you get the error only once a day might be related to caching.

#2

Updated by Karsten Hachmeister over 14 years ago

I am using PHP 5.1.2 and also the APC cache, forgot to mention, so it is probably related to APC.

Will look if I can upgrade the APC cache.

I am running APC 3.0.12p2 - this seems the latest version, so I have to live with it in the moment.

#3

Updated by Oliver Hader over 14 years ago

You could try with the latest Debian package of the testing branch for PHP5: http://packages.debian.org/testing/web/php5

Or additionally could generally extend your /etc/apt/sources.list by debian packages of testing branch, so you don't have to wait for Ubuntu. But consider, that you're using possibly unstable releases then...

#4

Updated by Oliver Hader over 14 years ago

I had some minutes to dig into the c code of APC. It seems, that my previous suggestion won't help. So it seems to be only an APC problem. Could you please disable APC on your system to test if the error disappears? Thanks!
If so, it's not a TYPO3 concern and I'm going to close this bug-report.

#5

Updated by Oliver Hader over 14 years ago

Seems to be a PHP APC problem and not a general TYPO3 issue.
If the problem still exists after a patch for APC is available, you can reopen this bug-report.

Also available in: Atom PDF