Bug #17058

foreign_unique without foreign_selector doesn't work

Added by Oliver Hader over 12 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2007-03-01
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
5.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If in TCA on the parent side a field of type "inline" is defined to be unique ("foreign_unique") and no selector is used ("foreign_selector") this will produce a JavaScript error.
The reason is a wrong value delivered by JSON concerning uniqueness/selector.

Use the IRRE Testsuite from http://inpublica.de/typo3/T3X_irre_testsuite.t3x, create new company and person records of type "[IRRE Foreign Field Attributes] ..." and then try to relate companies to persons by using the select field of the child records.

This issue was reported by Thomas Murphy on the irre-list, see http://lists.typo3.org/pipermail/typo3-project-irre/2007-February/000020.html
(issue imported from #M5098)

0005098.patch View (1.88 KB) Administrator Admin, 2007-03-01 09:28

History

#1 Updated by Oliver Hader over 12 years ago

The attached patch file 0005098.patch should fix this bug.

#2 Updated by Thomas Murphy over 12 years ago

Works! :)

#3 Updated by Oliver Hader over 12 years ago

Committed to Trunk.

#4 Updated by Chris topher over 7 years ago

  • Target version deleted (0)

Also available in: Atom PDF