Bug #17206

Problem ignoring extension constraints

Added by Jeff Segars over 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
-
Start date:
2007-04-13
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When an extension has several types of constraints (dependencies, suggestions, and conflicts) problems can result when trying to install the extension.

As long as there are unresolved constraints in a category, a hidden input box is used to keep track of the constraints that have already been ignored. When all constraints in a category have been resolved, however, the hidden input boxes are no longer used. This causes problems when one category of constraints has been resolved but another has not.

For example, I can have extension dependencies and suggestions. I click ignore for all the suggestions and click the "Try Again" button. When I do this, the resulting page only shows my dependencies. I then resolve these dependencies and click the "Try Again" button again. When I do this, the ignored suggestions come back because they were not tracked on the previous page.

The solution is to keep the hidden input boxes and any associated text around even if all the constraints in a category have been resolved. I'm attaching a patch that should accomplish this.

(issue imported from #M5421)

class.em_index.php.diff View (1.11 KB) Administrator Admin, 2007-12-05 01:00

em_test.t3x (743 Bytes) Administrator Admin, 2007-12-05 01:00

History

#1 Updated by Jeff Segars about 12 years ago

I've updated the patch to apply cleanly to trunk now. I've also attached an example extension to demonstrate the problem.

When you install the example extension before applying the patch, choose to ignore only one of the suggestions and click the Try Again button. You'll end up in a loop, as the previous items you ignored are not remembered.

Once you apply the patch, hidden form fields track he previous items that have been ignored.

#2 Updated by Jeff Segars almost 12 years ago

Fix committed to trunk (changeset 2879) and 4.1 branch (changeset 2880).

Also available in: Atom PDF