Bug #17461

Parent record is not shown after saving the first time to a table on a TYPO3 system

Added by Oliver Hader over 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2007-07-11
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Imagine you have two tables tx_myext_parent and tx_myext_child and these tables are "fresh" or were truncated before.
If you create your first parent record with some children and save the parent record (not save&close), the correctly created parent record will not be shown.

The reason is in alt_doc.php. A check should prevent from showing newly created child records because the parent was initially edited. The new child records are memorized in TCEmain's array "newRelatedIDs".

(issue imported from #M5948)

0005948_41.patch View (919 Bytes) Administrator Admin, 2007-07-11 16:49

0005948_trunk.patch View (519 Bytes) Administrator Admin, 2007-07-11 16:49

History

#1 Updated by Oliver Hader over 12 years ago

Committed to SVN:
  • TYPO3_4-1 (rev. 2408)
  • Trunk (rev. 2409)

Also available in: Atom PDF