Bug #17594

browse_links and other popups don't work, when in Admin Panel "Editforms on-page" is checked

Added by Irene Höppner about 13 years ago. Updated about 13 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-09-12
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you use Frontend Editing and you check "Editforms on-page:" in the Admin Panel you won't be able to use several modules like the browse_links, acronym, user elements.

The reason is, that in tx_rtehtmlarea_base->loadJScode() the following condition has been added: is_object($TSFE). Thus the javascript-class-params (RTEtsConfigParams, pathAcronymModule, pathLinkModule, ..) are not set, as the needed javascript ist not included, if an object $TSFE is found.

$TSFE is not there, when using the popup for editing, but it is there, when editing inside the page with the above mentioned option.

In the patch I removed that condition, but as it was added in 4.1 and I don't know the reason for that, there might be some problems again at other places, that I didn't realise...
(issue imported from #M6326)

class.tx_rtehtmlarea_base.php.patch View (298 Bytes) Administrator Admin, 2007-09-12 10:52


Related issues

Duplicates TYPO3 Core - Bug #17602: rtehtmlarea doesn't work in front end editing in the mode "Forms on page" Closed 2007-09-14

History

#1 Updated by Stanislas Rolland about 13 years ago

In class.tx_rtehtmlarea_base.php all tests coded as

is_object($TSFE)

should be replaced by

is_object($TSFE) && !strstr($this->elementId,'TSFE_EDIT')

Also available in: Atom PDF