Bug #17733

IRRE childs reorder after deleted one

Added by Maxime Lafontaine over 14 years ago. Updated almost 14 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2007-10-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
5.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In an IRRE, I have a list of childs in a specified order.
If I add a child and save, and after I delete this child and save, the order of the childs is reset in reverse of their uid. ex:

I start:

uid: 5
uid: 2
uid: 3

I add one:

uid: 5
uid: 2
uid: 3
uid: 6

save

I delete and save:

uid: 5
uid: 3
uid: 2

I have this bug with IRRE of IRRE. I does'nt have time to test it with only a simple IRRE.

IRRE Type: 1:n (ext-->tt_content)
(issue imported from #M6609)


Files

tca.php (11.9 KB) tca.php Administrator Admin, 2007-10-30 14:26
T3X_testcase_6609-0_0_0-z-200710301457.t3x (12.5 KB) T3X_testcase_6609-0_0_0-z-200710301457.t3x Administrator Admin, 2007-10-30 14:57
#1

Updated by Oliver Hader over 14 years ago

Could you please attach the tca.php of your extension here?

#2

Updated by Maxime Lafontaine over 14 years ago

I've add my tca.php file.
The problem as occured in items of "content" of "$TCA["tx_nurebook_pages"]"

#3

Updated by Oliver Hader over 14 years ago

Thanks for the tca.php - so the sorting order of tt_content records gets mixed up on deleting a child record and saving the parent? I'm trying to reproduce this behaviour...

#4

Updated by Oliver Hader over 14 years ago

I could not reproduce this with a single 1:n relationship to tt_content (the test extension is attached). But you can send me your extension via e-mail to oh [at] inpublica (dot) de and I'm going to have a look at it again...

#5

Updated by Maxime Lafontaine over 14 years ago

We found that the extention push2rss was doing the problem. So if you use this extention, be aware!

#6

Updated by Oliver Hader over 14 years ago

Faulty TCEmain hook of extension "push2rss" is causing this issue.
No change of the TYPO3 Core required.

Also available in: Atom PDF