Bug #17939

Import/Export: Import of a .t3d does not fully create necessary directorys underneath fileadmin/templates

Added by Thomas Esders almost 12 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2007-12-19
Due date:
% Done:

0%

TYPO3 Version:
4.1
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I made an Export of a fresh installation after TV-mapping. The export is configured to include everything with infinit recusion.

When i try to import the .t3d file the import creates the directory "fileadmin/templates" correctly. The needed file "index.html" is also in the right place. But the importer creates a directory "fileadmin/templates/indexed_FILES" which is wrong. It should be "fileadmin/templates/styles" and "fileadmin/templates/images".

I tried to include the needed files via "Ressource" field in my main TypoScript template but the result was the same.

The error can be reproduced.

If you need it, i can provide a .t3d which is "wrong" - just let me know!
(issue imported from #M7014)

History

#1 Updated by Stefano Cecere almost 12 years ago

yes, this is a bad behaviours of Import/export taht i never liked much..

i don't even know if it is really useful (i guess they made it work so to not ovewrite or something like that)

#2 Updated by Thomas Esders almost 12 years ago

Well in my opinion this is a bug. The importer should handle file references as it oes with pictures or dcuments included in a tt_content-record.

#3 Updated by Thomas Esders almost 12 years ago

I am not a programmer, but it seems to me, that i entered the following "else" in class.tx_impexp.php:

I will try to check the "update"-box when i import so see if this solves the problem...

02074 } else {
02075 // Create the resouces directory name (filename without extension, suffixed "_FILES")
02076 $resourceDir = dirname($newName).'/'.ereg_replace('\.[^.]*$','',basename($newName)).'_FILES';
02077 if (t3lib_div::mkdir($resourceDir)) {
02078 foreach($fileHeaderInfo['EXT_RES_ID'] as $res_fileID) {
02079 if ($this->dat['files'][$res_fileID]['filename']) {
02080 $absResourceFileName = $fileProcObj->getUniqueName($this->dat['files'][$res_fileID]['filename'], $resourceDir);
02081 $relResourceFileName = substr($absResourceFileName, strlen(dirname($resourceDir))+1);
02082 $this->writeFileVerify($absResourceFileName, $res_fileID);
02083
02084 $tokenizedContent = str_replace('{EXT_RES_ID:'.$res_fileID.'}', $relResourceFileName, $tokenizedContent);
02085 $tokenSubstituted = TRUE;
02086 }
02087 }
02088 }
02089 }

#4 Updated by Alexander Opitz over 6 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#5 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Bernhard Kraft)
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF