Bug #18258

Fix module menu alignment and hover in Internet Explorer

Added by Jeff Segars almost 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-02-20
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In Internet Explorer, labels in the module menu are not aligned the same as other browsers due to a collapsing span on the menu icons. Also, Internet Explorer 6 does not support the hover attribute on list elements.

To fix this, I've changed the icons to float left which allows IE and other browsers to give them a consistent width (regardless of icon size) and preserve the alignment in all browsers. For the hover, I've used a CSS selector within prototype to add and remove a hover class on mouseenter and mouseleave. These events are only available in IE, but thats fine since IE is our target.

(issue imported from #M7598)

20080220_IE_modulemenu.diff View (2.18 KB) Administrator Admin, 2008-02-20 16:26

History

#1 Updated by Jeff Segars almost 12 years ago

Committed to 4.2 branch.

Also available in: Atom PDF