Bug #18259

Remove checkbox border from t3skin in Internet Explorer

Added by Jeff Segars almost 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-02-20
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

t3skin defines a CSS style for input checkboxes that has no border, but this style is ignored by Internet Explorer since it doesn't support attribute selectors.

The solution is to dynamically add a class to all checkboxes using Prototype so that the CSS style can be targeted at that class.

(issue imported from #M7601)

20080220_IE_checkboxes.diff View (2.65 KB) Administrator Admin, 2008-02-20 18:14

History

#1 Updated by Jeff Segars almost 12 years ago

Committed to 4.2 branch.

Also available in: Atom PDF