Bug #18293

Hanging of TYPO3

Added by emds-itsupport over 13 years ago. Updated about 13 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2008-02-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TYPO3 (whether it is php, apache or mysql) sometimes hangs when trying to view the page on the front end. I have to restart TYPO3 and then it works for some time. The problem has occured when trying to view my Flex-based plug-ins, although I do not assert that comes from that.

(issue imported from #M7649)


Related issues

Is duplicate of TYPO3 Core - Bug #18279: Several problems with locking API (t3lib_lock)ClosedOliver Hader2008-02-22

Actions
#1

Updated by emds-itsupport over 13 years ago

It seems that this hanging which causes me to restart is due to a locking error. Following message is generated when I remove the locks folder:

Warning: touch() [function.touch]: Unable to create file C:/typo3c/htdocs/Quickstart/typo3temp/locks/55961bb3f3c4fa0ebb0d136f9a0ab51d because No such file or directory in C:\typo3c\htdocs\Quickstart\t3lib\class.t3lib_lock.php on line 153

Fatal error: Uncaught exception 'Exception' with message 'Lock file could not be created' in C:\typo3c\htdocs\Quickstart\t3lib\class.t3lib_lock.php:154 Stack trace: #0 C:\typo3c\htdocs\Quickstart\typo3\sysext\cms\tslib\class.tslib_fe.php(2746): t3lib_lock->acquire() #1 C:\typo3c\htdocs\Quickstart\typo3\sysext\cms\tslib\class.tslib_fe.php(1724): tslib_fe->acquirePageGenerationLock(Object(t3lib_lock), '578::') #2 C:\typo3c\htdocs\Quickstart\typo3\sysext\cms\tslib\index_ts.php(371): tslib_fe->getFromCache() #3 C:\typo3c\htdocs\Quickstart\index.php(76): require('C:\typo3c\htdoc...') #4 {main} thrown in C:\typo3c\htdocs\Quickstart\t3lib\class.t3lib_lock.php on line 154

#2

Updated by Oliver Hader over 13 years ago

Please create the directory ./typo3temp/locks/ and make it writable for the user your Apache is running with.
Concerning the locking you have to install one more patch "0007333_post_v2.patch" which is available at this bug report: #18084

#3

Updated by Oliver Hader over 13 years ago

Duplicate of #18279 - fix is attached there

Also available in: Atom PDF