Bug #18380

TCEForms extraFormHeaders do not work with docheaders

Added by Jeff Segars almost 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-03-05
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TCEForms has the possibility to set extraFormHeaders that are included above the editing form. In templates/alt_doc.html, the ###EXTRAHEADER### is included as part of typo3-docheader so that content from the editing form always scrolls behind it.

The problem is that the docbody has an absolute position so adding extra rows to the header does not push the actual editing form down.

I can see two options to work around this...
#1 - Move ###EXTRAHEADER### outside the docheader so that it scrolls behind the header just like other content
#2 - There's already Javascript code in place for IE to dynamically calculate the height and fix scrolling problems so we could remove the absolute positioning and let the Javascript run for all browsers.

I'm attaching a screenshot and a sample extension that adds extra headers to all records.

(issue imported from #M7768)

extraHeaders.png View (42.6 KB) Administrator Admin, 2008-03-05 21:04

T3X_test_docheader-0_0_0-z-200803051409.t3x (2.73 KB) Administrator Admin, 2008-03-05 21:07

7768.diff View (535 Bytes) Administrator Admin, 2008-03-18 14:52

History

#1 Updated by Steffen Kamper almost 12 years ago

Hi Jeff,

i can confirm this. The problem is here:

div#typo3-docbody {
width: 98%;
padding: 2% 0% 2% 2%;
overflow: auto;
top: 51px;
bottom: 0;
position: absolute;
z-index: 2;
}

You see that the div is alwas 51px from top, ignoring height of docheader.

I solved it in the pagetree filter-hiding with a additional marker in the docbody-div for inline style adding the needed margin.

#2 Updated by Steffen Kamper almost 12 years ago

I think best solution is to move the extrarow to typo3-docbody

#3 Updated by Steffen Kamper almost 12 years ago

try this in alt_doc.html:

<div id="typo3-docbody">
###EXTRAHEADER###
###CONTENT###
</div>

#4 Updated by Steffen Kamper almost 12 years ago

btw - same problem when using debug.

#5 Updated by Jeff Segars over 11 years ago

Committed to 4.2.

Also available in: Atom PDF