Bug #18422

Task center iframes are only sized on load

Added by Jeff Segars almost 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-03-10
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Within the task center, iframes are used to include external content such as a TCE form for editing records as part of sys_action. These iframes have an onload attribute to set the height of the form, but this event handler could be improved.

Other iframes within the new backend are automatically resized when the browser window is resized (via Prototype event handlers) so the task center should get this same behavior.

(issue imported from #M7820)

7820_user_taskcenter_calcHeight.diff View (2.05 KB) Administrator Admin, 2008-03-11 00:12

7820_user_taskcenter_calcHeight2.diff View (2.36 KB) Administrator Admin, 2008-03-11 18:02

7820_user_taskcenter_calcHeight3.diff View (2.45 KB) Administrator Admin, 2008-03-17 11:21


Related issues

Related to TYPO3 Core - Bug #18061: Taskcenter -> sys_action - viewport is too small when creating records Closed 2008-01-27

History

#1 Updated by Steffen Kamper almost 12 years ago

i changed the calc of parent height to prototype. Attached patch works for IE too.

#2 Updated by Jeff Segars almost 12 years ago

Thanks Steffen. Works for me in Firefox and Safari. Would it be possible to tie this to load or browser resize so that its always the correct size?

#3 Updated by Steffen Kamper almost 12 years ago

I did the rezising too.

I had to exclude IE6 because it crashes IE6. The Cause maybe interdependencies with other resize handlers in BE.

#4 Updated by Steffen Kamper over 11 years ago

change in fix no3 is the condition for IE6 like the other changes for that.

#5 Updated by Jeff Segars over 11 years ago

Committed to 4.2 branch. Thanks Steffen!

Also available in: Atom PDF