Bug #18517

Add icon to selected entry (currently icons are only shown in dropdown)

Added by Kasper Ligaard almost 13 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-03-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The dropdown boxes currently show icons in the dropdown menu, but not in the closed dropdown. This can be seen in e.g. the 'Type' field in a Page Element.

The attached patch add this.

As all this patch does is attach a style attribute to the select tag, the risk is very low.

Note that the patch uses it's own styling, since using the styling from function optionTagStyle() makes the dropdown box look bad.

Note: Opera does not show icons at all in the dropdown - with or without this patch.
(issue imported from #M7962)


Files

t3lib_tceforms-addIconToDropdownBox.patch (1.42 KB) t3lib_tceforms-addIconToDropdownBox.patch Administrator Admin, 2008-03-30 11:41
icon-in-dropdown-box.gif (4.27 KB) icon-in-dropdown-box.gif Administrator Admin, 2008-03-30 11:54
selector.png (12.7 KB) selector.png Administrator Admin, 2008-03-31 22:44
t3lib_tceforms-addIconToDropdownBox-rev1.patch (776 Bytes) t3lib_tceforms-addIconToDropdownBox-rev1.patch Administrator Admin, 2008-03-31 22:44
t3lib_tceforms-addIconToDropdownBox-rev2.patch (634 Bytes) t3lib_tceforms-addIconToDropdownBox-rev2.patch Administrator Admin, 2008-04-02 14:27
#1

Updated by Kasper Ligaard almost 13 years ago

Added small screenshot, showing the selector box after applying the patch.

#2

Updated by Dmitry Dulepov almost 13 years ago

rev 3483

#3

Updated by Kasper Ligaard almost 13 years ago

Oliver Hader reports a cosmetic problem for extensions without icons. Screenshot of problem and a patch uploaded shortly.

#4

Updated by Ingo Renner almost 13 years ago

committed the follow up patch

#5

Updated by Kasper Ligaard almost 13 years ago

It appears that the getIcon function returns 'gfx/' when no image is found(!). This nullifies the intended effect of the previous patch. Rev2 of the patch (uploaded shortly) fixes this by instead looking the icon info returned (which is empty).

#6

Updated by Ingo Renner almost 13 years ago

committed the follow up patch

Also available in: Atom PDF