Bug #19288

FlexForm configuration in extension: Localized flexform values are ignored

Added by Chi Hoang over 13 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-09-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

FlexForm configuration in extension: Localized flexform values are ignored when setting the be user language to a specific language. I.e. when disabling the language "<langDisable>1</langDisable>", the be user interface always shows the default language. Be-User language are fetched and loaded correctly. Be-Website language are fetched and loaded correctly, too. Enabling "<langDisable>0</langDisable>" the flexform configuration shows always all possible flexform configuration language.b

<T3DataStructure>
<meta>
<langDisable>1</langDisable>
</meta>
<sheets>
<sDEF>
<ROOT>
<TCEforms>
...
...
...

(issue imported from #M9290)


Files

taskCenter.gif (8.28 KB) taskCenter.gif Administrator Admin, 2008-09-04 17:05
flexformConfiguration.gif (10.7 KB) flexformConfiguration.gif Administrator Admin, 2008-09-04 17:07
patch.diff (531 Bytes) patch.diff Administrator Admin, 2008-09-10 21:02
#1

Updated by Chi Hoang about 13 years ago

When I write this into the T3DATASTRUCTURE and apply the attached patch, it seems to work for me.

<meta>
<langDisable>1</langDisable>
<langChidren>1</langChildren>
</meta>

#2

Updated by Chi Hoang over 12 years ago

To use this patch you must go to the Extension-Manager and select Translation handling and download a language.

#3

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#4

Updated by Alexander Opitz about 8 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF