Bug #19319

Internal caching in t3lib_pageSelect::getRootLine() has no effect

Added by Oliver Hader about 11 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-09-12
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The internal caching in t3lib_pageSelect::getRootLine() has no effect since the key to store the information ($uid) will always be "0" since the rootline is fetched from the current page up to the root page. Unfortunately the $uid gets overridden by the uid of the parent page in each step of the iteration.

(issue imported from #M9335)

0009335.patch View (1.72 KB) Administrator Admin, 2008-09-12 10:55

History

#1 Updated by Oliver Hader about 11 years ago

Committed to SVN:
  • TYPO3_4-2 (rev. 4258)
  • Trunk (rev. 4259)

Also available in: Atom PDF