Bug #19366

Selecting by tag using wildcards does not work with database disposal of t3lib_cache

Added by Oliver Hader about 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-09-22
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This issue concerns only the TYPO3 4.3 development branch.

When trying to select cached records by a tag containing wildcards, the new caching framework does not work for the database disposal.

Example:
$cache = $GLOBALS['TYPO3_CACHE']->create(
'whateverItMightBe',
't3lib_cache_VariableCache',
't3lib_cache_backend_Db',
array(...)
);
$cache->save('elementIdentifier', $content, array('someTag'));
$elements = $cache->loadByTag(array('someTag*'));

The variable $elements will have no items since the asterisk is not handled/converted correctly for the SQL query.

(issue imported from #M9408)

0009408.patch View (1.45 KB) Administrator Admin, 2008-09-22 16:38

0009408_v2.patch View (1.43 KB) Administrator Admin, 2008-09-24 12:56


Related issues

Related to TYPO3 Core - Bug #19385: SQL LIKE wildcards are not escaped correctly for list queries Closed 2008-09-28

History

#1 Updated by Oliver Hader about 11 years ago

Committed to Hackontest SVN branch
Still pending for Trunk!

#2 Updated by Oliver Hader about 11 years ago

Committed to SVN Trunk (rev. 4267)

Also available in: Atom PDF