Bug #19384

wrong cHash with additonalParams.wrap

Added by Ronald Steiner about 11 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-09-28
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This will lead to a wrong cHash:

typolink {
parameter.data = page:uid
no_cache = 0
useCacheHash = 1
additionalParams.data = GPvar:tx_myext_pi1|item
additionalParams.wrap = &&tx_myext_pi1[item]=|
additionalParams.outerWrap = |&tx_myext_pi1[list]=5
}

obviously cHash is generated before wrap and outerWrap are performed.

Has anyone else also observed this bug?

(issue imported from #M9441)


Related issues

Related to TYPO3 Core - Bug #17002: cHash is not recreated on disposal in config.linkVars Closed 2007-02-17

History

#1 Updated by Ronald Steiner about 11 years ago

wrong cHash leads to no caching of the page.
- so this is the resulting problem

#2 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF