Bug #19445

URLs in TYPO3 confirmation emails are broken and should be changed

Added by Gregor Schreier about 11 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2008-10-10
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

.....It is really an issue for regular users, they just click and the link is incorrect. It is cut just after the following characters:
http://TLD.com/confirm-registration.html?tx_srfeuserregister_pi1 [^]
Usually a hash value follows because I use shorturl mode....

this bug can be fixed, if you add < and > after the marker of your text template

like this:
<###SETFIXED_APPROVE_URL###>
<###SETFIXED_DELETE_URL###>

the breake is still there in the source-code of the mail,
but thunderbrid for example display it as a working link
(issue imported from #M9532)


Related issues

Related to TYPO3 Core - Bug #19104: Link doesn't work in thunderbird Closed 2008-07-14

History

#1 Updated by Franz Holzinger almost 11 years ago

Check this with the current test version at http://www.jambage.com/index.php?id=170 ,

#2 Updated by Agustin over 10 years ago

open typo3conf/ext/sr_feuser_register/lib/class.tx_srfeuserregister_email.php
and find the line where is

$Typo3_htmlmail->addPlain(str_replace("[","--",$PLAINContent));

and just above it add the following lines:

$PLAINContent = str_replace("[","--",$PLAINContent);
$PLAINContent = str_replace("]","++",$PLAINContent);

then go to index.php and find these lines:

// **********
// Constants defined
// **********

and under that, write these lines:

if ($_GET["tx_srfeuserregister_pi1--sFK__"]=="APPROVE") {
$url_self = str_replace("++","]",$_SERVER["REQUEST_URI"]);
$url_self = str_replace("--","[",$url_self);

//echo $url_self;
header("location: $url_self");
}

it's not the best, but it works for me. i hope this helps.

#3 Updated by Franz Holzinger over 10 years ago

You are replacing the '[' and ']' in the generated urls. This could help to get all confirmation links in every email client working. However this should not be fixed in this extension but generally in TYPO3. So make a feature request to this on the TYPO3 Core bug tracker.

#4 Updated by Jörg Wagner almost 10 years ago

Have a look at RFC 2396 on "URI generic syntax" ( http://www.ietf.org/rfc/rfc2396.txt ):

-------SNIP-------
2.4.3. Excluded US-ASCII Characters

Although they are disallowed within the URI syntax, we include here a
description of those US-ASCII characters that have been excluded and
the reasons for their exclusion.
The control characters in the US-ASCII coded character set are not
used within a URI, both because they are non-printable and because
they are likely to be misinterpreted by some control mechanisms.
control     = &lt;US-ASCII coded characters 00-1F and 7F hexadecimal&gt;
The space character is excluded because significant spaces may
disappear and insignificant spaces may be introduced when URI are
transcribed or typeset or subjected to the treatment of word-
processing programs. Whitespace is also used to delimit URI in many
contexts.
space       = &lt;US-ASCII coded character 20 hexadecimal&gt;
The angle-bracket "<" and ">" and double-quote (") characters are
excluded because they are often used as the delimiters around URI in
text documents and protocol fields. The character "#" is excluded
because it is used to delimit a URI from a fragment identifier in URI
references (Section 4). The percent character "%" is excluded because
it is used for the encoding of escaped characters.
delims      = "<" | ">" | "#" | "%" | <">
Other characters are excluded because gateways and other transport
agents are known to sometimes modify such characters, or they are
used as delimiters.
unwise      = "{" | "}" | "|" | "\" | "^" | "[" | "]" | "`"
Data corresponding to excluded characters must be escaped in order to
be properly represented within a URI.
-------SNAP-------

The bottomline is that this is NOT a mail client bug but that the URLs in TYPO3 confirmation emails should be changed. The square brackets should be escaped to %5B and %5D.
For some mail clients (like Apple mail app) it also works to enclose the URLs in quotes or angle brackets (as Gregor proposed in his original report). Both delimiters result in correct links in Thunderbird and other email clients (like Apple mail app).
But IMHO the way to go is escaping as the RFC recommends.

#5 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • TYPO3 Version set to 4.2

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#6 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF