Bug #19646

dividers get stripped when using method t3lib_extMgm::addFieldsToAllPalettesOfField()

Added by Ingo Renner over 12 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2008-11-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
when using t3lib_extMgm::addFieldsToAllPalettesOfField() to add new fields to palettes of an existing field dividers on the manipulated table get stripped except for the first one after the "General" divider.
This is caused by unpropper checking for the existence of a field name in t3lib_extMgm::getFieldsOfFieldList()

Solution:
In t3lib_extMgm::getFieldsOfFieldList() check whether we're processing a divider (--div--)

Notes:
The patch also renames/corrects the name of t3lib_extMgm::getFieldsOfFieldList() to t3lib_extMgm::getFieldsFromFieldList()

install EXT:openid and EXT:felogin. felogin adds a field that should appear under the Extended tab in fe_user records. openid adds a new field to a palette of the username field through the broken method and thus removes the dividers/tabs except for the first one after the General tab.

(issue imported from #M9845)


Files

9845_dividers.diff (3.6 KB) 9845_dividers.diff Administrator Admin, 2008-11-26 03:15

Related issues

Is duplicate of TYPO3 Core - Bug #19683: Extending palettes and fields to be displayed in back-end forms mixes up tabsClosedOliver Hader2008-12-04

Actions
#1

Updated by Oliver Hader over 12 years ago

The fix for this problem was committed in issue #19683 to SVN Trunk.

Also available in: Atom PDF