Feature #19889

displayErrors=2 and no errors on CLI

Added by Ernesto Baschny over 10 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-01-22
Due date:
% Done:

0%

PHP Version:
4.3
Tags:
Complexity:
Sprint Focus:

Description

Many sites set displayErrors=2 and have devIPmask to a list of IPs from the developer. This won't disturb the public, but the developer gets PHP errors, which is nice.

Unfortunately this also disables PHP errors from being outputted when running CLI scripts. This is particularly important if I set some cronjob running a CLI which can "break".

So suggested is a new setting displayErrorsForceOnCLI (boolean) which will enable error output on CLI, even if displayErrors=2.

(issue imported from #M10228)

History

#1 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback for over 90 days.

Also available in: Atom PDF