Bug #20124

Admin panel is not available anymore when extension fe_edit is not installed

Added by Oliver Hader about 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Communication
Target version:
-
Start date:
2009-03-03
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When the extension fe_edit (extracted functionality of frontend to separate system extension) is not installed the admin panel (config.admPanel=1) is not displayed anymore.

The admin panel should work without frontend editing since the admin panel is not only about content editing - but more about general information of the current page rendering.

(issue imported from #M10597)


Files

0010597_v4.patch (64.6 KB) 0010597_v4.patch Administrator Admin, 2009-05-22 19:02
#1

Updated by Oliver Hader about 12 years ago

  • moved typo3/sysext/fe_edit/view/class.tx_feedit_adminpanel.php to t3lib/class.t3lib_adminpanel.php
  • moved admin panel methods from t3lib_frontendedit to t3lib_AdminPanel
  • adjusted calls to the accordant functionalities
#2

Updated by Oliver Hader about 12 years ago

How to test this patch:
1) svn mv typo3/sysext/fe_edit/view/class.tx_feedit_adminpanel.php t3lib/class.t3lib_adminpanel.php
2) apply the patch

#3

Updated by Oliver Hader almost 12 years ago

Committed to SVN Trunk (rev. 5477)

Also available in: Atom PDF