Bug #20200

mailform has the same name and id even if used more than once

Added by Natalia Postnikova over 12 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-03-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If the mailform is inserted twice on the page, it has the same name and id in both cases. Therefore the validation does not work.

(issue imported from #M10715)

#1

Updated by Ole Fritz over 12 years ago

I can acknowledge that. Tested with TYPO3 Version 4.2.6.

#2

Updated by Natalia Postnikova over 12 years ago

if you insert this in your setup, a unique id will be generated for the form
tt_content.mailform.20.formName >

#3

Updated by Natalia Postnikova over 12 years ago

If you add this to your setup, a unique id will be generated for each form
tt_content.mailform.20.formName >

#4

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#5

Updated by Alexander Opitz about 8 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF