Bug #20716

ChangeLog is quite big and could be split to multiple files

Added by Ingmar Schlecht over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-07-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The ChangeLog file is getting bigger and bigger, though usually people are only interested in the changes since the last major revision.

In order to shorten (i.e. split up into multiple files) the file, Marcus Krause suggested the following to the dev mailing list:
_______________________________
If there's a consensus to shorten the file, we could handle it the way
e.g. apache does:
http://svn.apache.org/viewvc/httpd/httpd/trunk/CHANGES?revision=790587

Example for 4-2:

At the bottom of the file:
Changes with TYPO3 4-1:

(issue imported from #M11473)

#1

Updated by Ingmar Schlecht over 11 years ago

Closing this issue, because there are good arguments against doing this.

Citing Christian Kuhn:
-------------------------------------------------
- I quite often hunt for regressions / changes using svn log / svn diff,
and search in the Changelog (sometimes many years back). If I need to
jump through different files this would just be a waste of time. It just
helps my style of development if I have the full Changelog at one place.

- If I clean up old bugs in the bugtracker, I often like to search in
the full Changelog, too. If we separate the file I have to grep through
many files in different checkouts. This is inconvenient.

- I don't see a point in reducing the Changelog, a compressed Changelog
is currently less than 100kb big, with 6 years of history in it. Even if
this doubles or triples in size the next years ... I don't care, who does?

- Any serious administrator will delete Changelog, NEWS.txt and all
other static textfiles on production systems anyway, just to not give an
attacker too much helping information. Again, size is no argument here.
-------------------------------------------------

Also available in: Atom PDF