Bug #20784

Faulty usage of t3lib_matchCondition in backend template

Added by Oliver Hader over 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-07-27
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The backend base template (typo3/template.php) creates an instance of t3lib_matchCondition to determine browser information. However, it's not required to load the full t3lib_matchCondition class - besides that it's intended for TypoScript conditions in the frontend.
This is a classical misuse...

(issue imported from #M11585)

0011585_v2.patch View (12.1 KB) Administrator Admin, 2009-07-27 15:18

0011585_test.patch View (3.21 KB) Administrator Admin, 2009-07-27 15:39

0011585_v3.patch View (12 KB) Administrator Admin, 2009-08-02 00:59

0011585_test_v3.patch View (3.13 KB) Administrator Admin, 2009-08-02 01:05

History

#1 Updated by Oliver Hader over 10 years ago

Committed to SVN Trunk (rev. 5747)

Also available in: Atom PDF