Bug #21190

Suggest: Function call on a non-object

Added by Stefan Froemken over 11 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-10-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I'm working with current trunk and get following error, when I try to edit a database record in list modul:

Fatal error: Call to a member function init() on a non-object in C:\xampp_webserver\htdocs\t3lib\class.t3lib_tceforms.php on line 402

Windows
XAMPP 1.7.2
PHP 5.3
Trunk version of TYPO3 4.3-dev

I replaced following line in class.t3lib_tceforms.php:

$this->suggest->init($this);

with:

if(!is_object($this->suggest)) {
$this->suggest = t3lib_div::makeInstance('t3lib_TCEforms_suggest');
}
$this->suggest->init($this);

and now it works for me.
(issue imported from #M12120)

#1

Updated by Nicole Cordes about 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

I think this can be closed for now and is already resolved?!

#2

Updated by Stefan Froemken about 8 years ago

Yeah...this ticket is really dusty :-) hust
Since TYPO3 4.5 I have no more problems with this cool feature.
You can close it.

#3

Updated by Nicole Cordes about 8 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF