Bug #21211

Several bugfixes and features by Kasper

Added by Oliver Hader about 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-10-09
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Several bugfixes and features have been committed to SVN Trunk (rev. 6116-6122) by Kasper:

  • Tiny bug with date function in t3lib_befunc. Casted timestamp to integer.
  • Added User TSconfig option "options.checkPageLanguageOverlay" so flexforms only show language fields for languages available on the page.
  • Fixed problem with notification emails to users when a workspace review rejection happens. Now it works
  • Added possibility to reset the diff-information for localizations so translators or admins can click a button that will mark a record so it appears to be in need of translation again.
  • Fixed problem with "Save and view" for new pages: Simply removed the button for new pages because it didn't choose the right PID anyway.
  • Implemented an override of allowed language per workspace. This is an expert feature available as a USER TSconfig option "options.workspaces.allowed_languages"
  • Expanded the feature that disables/enables login in a branch so now you can allow a login but force the usergroups to be "0,-2" (basically, that no usergroups are set for the user). This can help to reduce multiple caching of similar pages in case of many usergroup combinations in a system.
  • Implemented a simple hook after retrieval of a page from cache.
  • Fixed bug in Addwizard: It didn't work properly with wizard for other pages. Took the wrong table name. Thanks to Hassan AIT ABDELLAH, Dassault Systemes, for the fix.

http://forge.typo3.org/repositories/revision/typo3v4-core/6116
http://forge.typo3.org/repositories/revision/typo3v4-core/6117
http://forge.typo3.org/repositories/revision/typo3v4-core/6118
http://forge.typo3.org/repositories/revision/typo3v4-core/6119
http://forge.typo3.org/repositories/revision/typo3v4-core/6120
http://forge.typo3.org/repositories/revision/typo3v4-core/6121
http://forge.typo3.org/repositories/revision/typo3v4-core/6122
(issue imported from #M12162)

0012162.patch View (18 KB) Administrator Admin, 2009-10-09 10:36

0012162_followup_r6120.patch View (2.03 KB) Administrator Admin, 2009-10-09 10:53

Also available in: Atom PDF