Bug #21338

Menu in alt_main does not react to clicks

Added by Oliver Klee over 10 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-10-22
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Steps to reproduce:

1. Log in to the BE.
2. enter ..../typo3/alt_main.php in the URL bar
3. click on Web > Page (or any other menu item)

Expected results:
the page tree is shown, and no error messages on Firefox' error console

Actual results:
No visible result to clicks, and the following error message on the error console:

Fehler: top.rawurlencodeAndRemoveSiteUrl is not a function
Quelldatei: http://typo4test/typo3/alt_menu.php
Zeile: 266

I've tested this in the trunk and the 4.2.x branch; I don't know whether 4.1.x is affected as well.

It looks like alt_main isn't used much anymore (or we would have had this bug report much earlier), especially not by the Core developers (alt_main isn't "dog food" anymore). So I suggest to just removed alt_main and all then-unused files for 4.3. This will also make maintenance easier.
(issue imported from #M12312)


Related issues

Related to TYPO3 Core - Bug #22701: Remove old_backend Closed 2010-05-23
Related to TYPO3 Core - Bug #20844: TYPO3 Javascript object missing in alt_main.php Closed 2009-08-06
Duplicates TYPO3 Core - Bug #20022: old/classic BE --> top.rawurlencodeAndRemoveSiteUrl is not a function Closed 2009-02-16

History

#1 Updated by Chris topher over 9 years ago

After the old BE was removed in #22701:

Resolved no change required.

#2 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF