Bug #21349

DOM object identifiers use invalid characters

Added by Oliver Hader over 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-10-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The DOM object identifier that are created for nested elements of Inline Releational Record Editing contains invalid characters. Object identifiers are use in IRRE to determine each level of nestification, examle:
data11[tx_irretutorial_1nff_offer][4][prices][tx_irretutorial_1nff_price][7]

JavaScript methods that are executing CSS selections, will not work anymore (i.e. currently deleting child records in the forms view is not possible anymore). It's not a problem of the JavaScript frameworks like prototype.js, the reason are the invalid characters.

However the character "[" and "]" are invalid for being used as DOM object identifier. Thus, the separator has to be changed and accordant parts in the Core have to be adjusted, example:
data-11-tx_irretutorial_1nff_offer-4-prices-tx_irretutorial_1nff_price-7

(issue imported from #M12327)


Files

0012327.patch (28 KB) 0012327.patch Administrator Admin, 2009-10-23 19:29
0012327_v2.patch (30.2 KB) 0012327_v2.patch Administrator Admin, 2009-10-26 15:58

Related issues

Related to TYPO3 Core - Bug #20963: Child records cannot be deleted inlineClosedOliver Hader2009-08-31

Actions
Related to TYPO3 Core - Bug #21367: Click on Delete at IRRE Record throws JavaScript Exception...ClosedOliver Hader2009-10-26

Actions
Related to TYPO3 Core - Bug #21369: JavaScript-Error with "useSortable => 1" with more than one inline elementClosedOliver Hader2009-10-26

Actions
Related to TYPO3 Core - Bug #21205: deleting of Irre Elements does not workClosedOliver Hader2009-10-08

Actions
Related to TYPO3 Core - Bug #21434: Cannot add new elements on second level of nestingClosedOliver Hader2009-11-03

Actions
#1

Updated by Stefan Geith over 11 years ago

This patch fixes the related issue 0011835, but introduces other 'missbehaviour':

- Inline Records, that are collapsed, do not expand any more.
- Inline Record only expands, if it is only one single record.

#2

Updated by Oliver Hader over 11 years ago

Thanks for the feedback! As already written to the Core List, v2 of the patch fixes some other misbehaviours.

#3

Updated by Oliver Hader over 11 years ago

Committed to SVN Trunk (rev. 6277)

Also available in: Atom PDF