Bug #21364

Integrate check to the install tool and reports module concerning eAccelerator

Added by Oliver Hader about 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-10-26
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There are some parts in the TYPO3 Core that require annotation parsing, e.g. Extbase and the unit tests. These parts grab the PHPdoc comments and search for annotations like "@test".

However, since eAccelerator can be compiled to strip all comments away, this would produce strange behaviours. Thus it's recommended to compile eAccelerator with this configuration:

--with-eaccelerator-doc-comment-inclusion

See also first section concerning Extbase in the 4.3-alpha3 release notes:
http://news.typo3.org/news/article/typo3-43-alpha-3/
(issue imported from #M12347)

12347.diff View (1.15 KB) Administrator Admin, 2009-11-04 19:19

eaccelerator.png View (18.3 KB) Administrator Admin, 2009-11-04 19:20

History

#1 Updated by Steffen Kamper about 10 years ago

I added the check for install tool. However as it'S not really needed for prduction use i think we don't need same check in reports module, as extbase already have it.

#2 Updated by Steffen Kamper about 10 years ago

committed to trunk, rev 6362

Also available in: Atom PDF