Bug #21402

spamProtectEmailAdresses does not encrypt:decrypt 1:1

Added by Morten Nisker over 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-10-29
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

There is a problem with spamProtectEmailAdresses. If you add a subject to a mail link, some chars can break the javascript and if the problematic chars are URL encoded they are not always decrypted to the same char.

Example.
a subject added to the mailto link

mailto:?subject=Regarding the page: Morten's test page
the ' char will break the javascript.
If I then urlenocde the string so I have the following:
mailto:?subject=email%20emne Morten%27s%20test%20page

I end up with something like this in my mail client:
Regarding@the@Page@MortenGs@test@page

I think there are two bugs here, one is that the generated script does not URL encode by it self and second that is does not decode correctly.
(issue imported from #M12395)

History

#1 Updated by Morten Nisker over 10 years ago

TYPO3 Version 4.3

#2 Updated by Alexander Opitz about 7 years ago

  • Category deleted (Communication)
  • Status changed from New to Needs Feedback
  • Target version deleted (-1)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3 Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF