Bug #21702

The type in t3lib_TCEforms does not work if the type field shall be excluded when translating

Added by Fabrizio Branca about 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-11-26
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
When defining a field as 'type' field in TCA and defining this field as l10n_mode "exclude" the type field will not be respected when editing the language overlay records. This is the case if you want to prevent language versions to switch the type (which in my opinion is the most common case)

Solution:
Check if the type field is an exclude field and if so, then read the typeNum value from the default language's data

(issue imported from #M12781)

12781.patch View (1013 Bytes) Administrator Admin, 2009-11-26 17:53

12781_v2.patch View (1.02 KB) Administrator Admin, 2009-12-16 15:57

History

#1 Updated by Oliver Hader about 10 years ago

Committed to SVN Trunk (rev. 6590)

#2 Updated by Fabrizio Branca about 10 years ago

I fear with committing my last patch we introduced a new bug:

While everything works fine for the translation record (the problem was, that the type field was not taken into account there) now the original record in the default language ignores the value of its type field (if l10nmode=='exclude', as defined in the orginal post...) and always shows the fields of the default type.

#3 Updated by J. Peter M. Schuler about 10 years ago

Agreed, current stable has the problem, that type field isn't working if typefield l10n_mode is set to exclude.

Tested on own extension because typefield was ignored after TYPO3 Core Update to 4.3. Commenting out the l10n_mode line in the extension TCA hotfixes the problem. Other extensions like tt_news without l10n_mode set work fine also, so it seems Fabrizio is right.

Supplied patch works as well.

#4 Updated by Ingo Renner over 9 years ago

If the problem still exists, could you please open a new issue. I'm going to close this one now as it's marked fixed.

Also available in: Atom PDF