Bug #21728

Core labels need to be utf-8 before json_encode

Added by Steffen Kamper over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-11-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This is same problem as #21727 and #21727. As json_encode only works with utf-8 the labels has to be converted if renderCharset is different.

This is for backend.php and same for pageRenderer.

(issue imported from #M12827)


Files

12827.diff (9.07 KB) 12827.diff Administrator Admin, 2009-11-28 21:16
12827_v2.diff (7.77 KB) 12827_v2.diff Administrator Admin, 2009-11-29 14:33
12827_v3.diff (7.81 KB) 12827_v3.diff Administrator Admin, 2009-11-29 16:34

Related issues

Related to TYPO3 Core - Bug #21727: Wrong encoding of labels in t3editorClosedOliver Hader2009-11-28

Actions
Related to TYPO3 Core - Bug #21709: Recycler does not show upClosedOliver Hader2009-11-26

Actions
Related to TYPO3 Core - Bug #21731: Wrong encoding of JSON data in t3lib_PageRendererClosedOliver Hader2009-11-29

Actions
#1

Updated by Chris topher over 11 years ago

This problem can also arise in extensions (e.g. with feeditadvanced).
Is there a way to fix this in the core, too?

#2

Updated by Steffen Kamper over 11 years ago

with this patch extensions should use the API (pageRenderer) to add labels and settings, then they are safe.

#3

Updated by Oliver Hader over 11 years ago

Hi Steffen, I've put the t3lib_PageRenderer part to a separate issue in #21731 since some more changes were required there.

#4

Updated by Steffen Kamper over 11 years ago

Hi olly,

ok, here is patch for backend.php only. I'll send it to core list right now.

#5

Updated by Steffen Kamper over 11 years ago

committed v3 to trunk, rev 6581

Also available in: Atom PDF