Bug #21990

felogin ie8 session cookie

Added by Roman Büchler about 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
-
Start date:
2010-01-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Currently I run several sites on one typo3 installation (version 4.3.1). A frontend user can perform the login but once he accesses an other page his identification gets lost.

Reading around I found that the compatibility mode might break the session. Therefore I added <meta http-equiv="X-UA-Compatible" content="IE=8" /> to the page header and veryfied the page to be valid in html, css and js.

When deleting the session cookies (through developer tool bar and not closing the browser, hence session) the auto logoff disapears and everything works fine.

As well I observed that the cookie domain isn't denominated correctly. In firefox the domain value is .venandar.com where in ie8 one just finds .com.

As well I read that upen setting [SYS][cookieDomain] the problem might disapear as well but using this parameter on a multi domain installation doesn't seem to be aproriate.

sr_feuser_register 2.5.8 is installed as well
(issue imported from #M13293)


Related issues

Is duplicate of TYPO3 Core - Bug #22084: Session/Login not working in IE8 across subdomainsClosedErnesto Baschny2010-02-08

Actions
#1

Updated by Georg Leitner almost 11 years ago

also check #11858

#2

Updated by Georg Leitner almost 11 years ago

I'm using felogin 1.3.0 (Latest revision 6647 from http://forge.typo3.org/)
on a fresh Typo3 4.3.1

searching this issue I found some hints, but none works for me:

localconf.php: $TYPO3_CONF_VARS['SYS']['cookieDomain'] = $_SERVER['SERVER_NAME'];

config.sendCacheHeaders = 0
config.sendCacheHeaders_onlyWhenLoginDeniedInBranch = 0

It seems that old loginboxmacmade doesn't have problems with IE8.

#3

Updated by Ernesto Baschny almost 11 years ago

Please check #13470 for the issue of FE-Logins in IE8. RFC is in core list, review, test and give you +1 there if the patch solves your problem.

Also available in: Atom PDF