Bug #22050

Delete page problem with pages_language_overlay

Added by Uros over 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-02-03
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I delete a page with 5 pages_language_overlay it always deletes pages_language_overlay that have the same pid as those deleted pages_language_overlay uid.

For example:
If I have a page with id 67 and pages_language_overlay with ids (112,113,114,115,116) in pid 67, and then try to delete this page with id 67, then TYPO3 deletes a page with uid 67 and pages_language_overlay that are in pid 67 which is OK, but it also deletes pages_language_overlay that are in pid (112,113,114,115,116) which is NOT OK. TYPO3 traverses those uids till there are no pages_language_overlay to delete.

I have tried this on TYPO3 4.3 and 4.3.1 and the error is the same.
On older version of TYPO3 like 4.2.11 it works just fine.

I hope I was clear enough.

I have also submitted sample.sql with sys_languages, pages and pages_language_overlay in it just to have the same page tree structure.

Just try to delete for example the page with id 67 and check log.

(issue imported from #M13414)

sample.zip (405 KB) Administrator Admin, 2010-02-03 14:53


Related issues

Duplicates TYPO3 Core - Bug #22034: Recursive deletion of alternative page languages Closed 2010-01-31

History

#1 Updated by Juan Pablo Villaverde over 9 years ago

I'm experiencing the same issue in a production website. It's a very relevant bug, the sites using multilanguage support are lossing information!

It's a recursive procedure, check this log:

05:40:37 admin@LIVE DB Delete Record 'xxx' (pages_language_overlay:543) was deleted from page 'Test Galeria' (638)
. . . . Record 'Playa Muscleres' (pages_language_overlay:242) was deleted from page 'Playa Muscleres' (543)
. . . . Record 'Mit dem Auto Tossa' (pages_language_overlay:118) was deleted from page 'Llegar en coche Tossa de Mar' (242)
. . . . Record 'Strände Tossa de Mar' (pages_language_overlay:54) was deleted from page 'Playas Tossa de Mar' (118)
. . . . Record 'Beaches Tossa de Mar' (pages_language_overlay:486) was deleted from page 'Playas Tossa de Mar' (118)

#2 Updated by Abdalla Bushnaq over 8 years ago

I have the feeling that this bug is related to 13380, and as that bug is fixed, this bug might also be actually fixed.

#3 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Closed
  • Target version deleted (0)

Closing as duplicate of #22034

Also available in: Atom PDF