Bug #22707

Proposal to add an error message

Added by Radu Dumbraveanu over 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-05-24
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Recently I've uploaded and installed typo3 on a server with an empty t3lib/csconvtbl folder, i.e. with no charset conversion tables. In result no labels where displayed in BE, it took me about a half of hour to find where is the problem and to upload the corresponding .tbl files.

So my proposal is to add an error message to the initCharset function from class.t3lib_cs.php file in case the conversion table file can not be found. For example like in readLLXMLfile function from class.t3lib_div.php file when the XML file does not exist.

(issue imported from #M14468)

History

#1 Updated by Chris topher over 9 years ago

I don't understand why this folder was empty in your installation: It is part of the Core and should always be installed with it. The supplied readme also states that the files are needed in TYPO3.

If you want to have a check, if TYPO3 was uploaded successfully, I suggest to use the md5-hash of the whole Core directories. But I am not sure, if having something like that is really needed... However, if you want to, you are welcome to come up with a patch!

#2 Updated by Alexander Opitz over 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#3 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF