Bug #23499

XHTML validity of backend when sys_action is loaded

Added by Ernesto Baschny about 9 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-09-03
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

sys_action is able to generate links for the backend.php toolbar. The links with a href and "&" parameters, but this is not properly escaped (htmlspecialchars missing).

Solution is to escape the links, so that that part gets XHTML valid.

Problem is there since 4.3 where the toolbar was added.
(issue imported from #M15635)

15635.diff View (697 Bytes) Administrator Admin, 2010-09-03 19:52

History

#1 Updated by Ernesto Baschny about 9 years ago

Commited to:

- trunk (rev. 8766, for 4.5alpha2)
- 4_4 (rev. 8767, for 4.4.3)
- 4_3 (rev. 8768, for 4.3.6)

#2 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF