Bug #24057

Install tool cannot compare "ENGINE" of MySQL Tables when DBAL is active

Added by Ernesto Baschny over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2010-11-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In core rev. 3365 (2008, was included in 4.2beta3), Stucki implemented a way of the Install Tool "COMPARE DATABASE" to change the Engine of a database. This does not work with DBAL enabled, because that change in t3lib_db was not ported to DBAL.

You end up with the same suggestions over and over again (to change Engine to "InnoDB" while the tables are already InnoDB).

(issue imported from #M16392)


Files

16392-dbal.patch (617 Bytes) 16392-dbal.patch Administrator Admin, 2010-11-15 11:24
16392_followup.diff (881 Bytes) 16392_followup.diff Administrator Admin, 2010-12-01 10:49
#1

Updated by Ernesto Baschny over 10 years ago

Attached fix solves the problem, which is present in 4.2 ... trunk.

#2

Updated by Xavier Perseguers over 10 years ago

Thanks for this bug report. Actually I was aware of the "problem" but did not investigate.

#3

Updated by Xavier Perseguers over 10 years ago

Committed to:

- DBAL trunk (rev. 40420)
- DBAL_1-1 (rev. 40421)
- DBAL_1-0 (rev. 40422)

#4

Updated by Xavier Perseguers over 10 years ago

I just figured out that native tables could not be retrieved anymore. Follow-up patch fixes this.

#5

Updated by Xavier Perseguers over 10 years ago

Follow-up committed to:

- DBAL trunk (rev. 40701)
- DBAL_1-1 (rev. 40702)
- DBAL_1-0 (rev. 40703)

Also available in: Atom PDF