Bug #24326

CSH: no box-shadow property in IE < 9 and other less capable browsers

Added by Peter Foerger almost 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-12-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We have a nice box-shadow on the CSH-Box but unfortunately no fallback solution yet for less capable browsers. Without any borders the CSH-Box doesn't visually overlay the background in these browsers (before.png).
The attached patch uses Modernizr, which is part of TYPO3 4.5 since beta1, to provide a fallback solution. (after.png)

(issue imported from #M16729)


Files

16729 .diff (492 Bytes) 16729 .diff Administrator Admin, 2010-12-12 20:14
before.png (3.44 KB) before.png Administrator Admin, 2010-12-12 20:14
after.png (3.35 KB) after.png Administrator Admin, 2010-12-12 20:14

No data to display

Also available in: Atom PDF