Bug #24516

Backwards compatibility in PHP_SCRIPT and accessing $this-> methods

Added by Ernesto Baschny almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Must have
Category:
Communication
Target version:
-
Start date:
2011-01-11
Due date:
% Done:

0%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Older sites might include PHP_SCRIPT cObject accessing cObject methods through $this->. Since the PHP_SCRIPT object was moved to its own class, the old methods will stop working (e.g. older "languageMenu.php" or stuff like http://www.sk-typo3.de/awstats-Zaehlen-von-Dateidownloads.55.0.html

Solution is to add a __call() catch-all to PHP_SCRIPT intercepting those calls and passing them to $this->cObj, while making a note of it in deprecation log.
(issue imported from #M16970)

History

#1 Updated by Ernesto Baschny almost 9 years ago

Committed to trunk, rev. 10029.

#2 Updated by Susanne Moog over 8 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF