Bug #24634

Make the t3lib_utility_Mail hook subscriber optional / configureable

Added by Ernesto Baschny over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2011-01-18
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

t3lib_utility_Mail::mail subscribed hook allows "old applications" which used to send mail through it to go through SwiftMailer instead.

This allows old extensions which haven't been ported to make use of SwiftMailer to gain access to the configurability of SwiftMailer (different transports) and send RFC conformant E-Mails.

This works fine for simple cases but will fail as soon as the sending application already tried to create the MIME confirmity itself (e.g. by using other libraries or doing it on its own). We don't want to add a full MIME parsing routines in Core just because of that backwards compatibility!

Since this cannot be detected, we implement a switch to disable the subscribed hook.

So if your installation uses some extension which sends mails, test if it works and that the generated mails are ok "out of the box" (which means that the SwiftMail hook is working), if it is not working (e.g. empty body of the mail, wrong attachment count, or garbled mail content), use the switch to turn the hook off (which also means that the configured transport under [MAIL] are not regarded anymore, and mails are send using the old school mail() method.

(issue imported from #M17109)

History

#1 Updated by Ernesto Baschny over 8 years ago

Committed to trunk, rev. 10151.

#2 Updated by Susanne Moog over 8 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF