Bug #24784

Workspaces module get place on "top" of all modules

Added by Ernesto Baschny over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2011-01-25
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After uninstalling the new sysext "info", the Workspaces module is on the first position of the modules menu (even before "Web>Page").

Since we moved several old hardcoded modules to sysext, they can also be uninstalled. Some extensions place their backend modules using the t3lib_extMgm::addModule() call and setting the $position parameter to one of these old hardcoded extensions.

E.g. the workspaces module registers himself for "before:info". So if "info" is not installed, the default would be to be placed "at the end". This is even documented in the method addModule(), but it doesn't work.

This is related to #24271 and a follow-up after this fix was applied: #24271
(issue imported from #M17282)


Related issues

Related to TYPO3 Core - Bug #23900: File module is shown although not loaded Closed 2010-11-01
Related to TYPO3 Core - Bug #24271: New sysext modules are placed incorrectly in the Web> module menu Closed 2010-12-02

History

#1 Updated by Ernesto Baschny over 8 years ago

Committed to trunk, rev. 10289.

Also available in: Atom PDF