Bug #24271

New sysext modules are placed incorrectly in the Web> module menu

Added by Ernesto Baschny over 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-12-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since #23599 the old "hardcoded" sysext list, perm, func and info lost their "fixed place" in the Web> modules menu. They now rely (like any other extension) in t3lib_extMgm::addModule().

Since they used to have after:layout in its calling, they were positioned after the "Web>Page" module. But since all had this property, they got added in the opposite order as intended.

We still don't have any other way to position modules besides "after" and "before", which is not flexible enough. Until we have a solution, I remove the hardcoded "after:layout" so that they get added in the order of loading (in extList). In the dummy + intro package I will order them correctly so that they appear after Page.

Your ordering might vary depending on when you installed those extensions.

(issue imported from #M16643)


Files

16643.diff (2.07 KB) 16643.diff Administrator Admin, 2010-12-02 01:19

Related issues

Related to TYPO3 Core - Bug #24784: Workspaces module get place on "top" of all modulesClosedErnesto Baschny2011-01-25

Actions
Has duplicate TYPO3 Core - Bug #23900: File module is shown although not loadedClosed2010-11-01

Actions
#1

Updated by Ernesto Baschny over 10 years ago

Committed to trunk, rev. 9746

#2

Updated by Susanne Moog about 10 years ago

  • Target version deleted (4.5.0)

Also available in: Atom PDF