Bug #24786

Formprotection persistToken method is called too often, causing unnecessary DB-load

Added by Helmut Hummel over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2011-01-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
To asure that in all cases the tokens get persisted, I added the persistToken call way too often

Solution:
Remove most of the calls and add one in template->endPage instead, since this is a central exit point for all modules.
Thanks for Steffen Kamper for the idea.

Note: A few places are left, where the template object is not used, thus the persist method needs to be called there.

(issue imported from #M17284)


Files

17284.diff (10.2 KB) 17284.diff Administrator Admin, 2011-01-25 03:50

Related issues

Related to TYPO3 Core - Bug #24671: Protect C(R)UD actions against CSRFClosedErnesto Baschny2011-01-20

Actions
#1

Updated by Ernesto Baschny over 10 years ago

Committed to trunk, rev. 10295.

Also available in: Atom PDF