Bug #24799

Unable to set new Install Tool Password

Added by Marcus Schwemer over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2011-01-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If I try to set a new Install Tool Password, I get the following error message:

"Validating the security token of this form has failed. Please reload the form and submit it again. "

Afterwards the Install Tool reports:

"No values were changed, so nothing is updated!"

So the password is not updated.

How to test:
- Delete your individual $TYPO3_CONF_VARS['BE']['installToolPassword'] from your localconf.php, so that there is only the default value for joh316.
- Create the ENABLE_INSTALL_TOOL in typo3conf
- Login to the backend. The warning message appears, that there is the the default set.
- Go to the Install Tool and try to change it.
- Have a look at your localconf.php or logout and login to the be again. The warning remains.

There is no difference whether you use the install tool in the BE or as a standalone.

(issue imported from #M17299)


Files

17309.diff (12.3 KB) 17309.diff Administrator Admin, 2011-01-25 19:21

Related issues

Related to TYPO3 Core - Bug #24671: Protect C(R)UD actions against CSRFClosedErnesto Baschny2011-01-20

Actions
Related to TYPO3 Core - Bug #24790: Form protection tokens get lost because of a race condition when persisting tokensClosedErnesto Baschny2011-01-25

Actions
#1

Updated by Steffen Kamper over 10 years ago

Committed to trunk rev 10308

Also available in: Atom PDF